Главная Войти О сайте

Как вычислить определённый интеграл в Excel

Давайте разберёмся, как вычислить определённый интеграл таблично заданной функции с помощью программы Excel из состава Microsoft Office.Как вычислить определённый интеграл в ExcelВам понадобится

Допустим, у нас есть таблично заданная некоторая величина. Для примера пусть это будет накопленная доза радиации при авиаперелёте. Скажем, был такой эксперимент: человек с дозиметром летел на самолёте из пункта А в пункт Б и периодически измерял дозиметром мощность дозы (измеряется в микрозивертах в час). Вас, возможно, это удивит, но при обычном перелёте на самолёте человек получает дозу радиации в 10 раз больше, чем фоновый уровень. Но воздействие это кратковременное и поэтому не опасное. По результатам измерений у нас есть таблица вот такого формата: Время - Мощность дозы.Как вычислить определённый интеграл в Excel

Суть метода в том, что определённый интеграл - это площадь под графиком нужной нам величины. В нашем примере, если полёт длился почти 2 часа, с 17:30 до 19:27 (см. рисунок), то чтобы найти накопленную дозу, нужно определить площадь фигуры под графиком мощности дозы - графиком таблично заданной величины.Как вычислить определённый интеграл в Excel

Вычислять интеграл мы будем самым простым, но довольно точным методом - методом трапеций. Напомню, каждую кривую можно разделить на трапеции. Сумма площадей этих трапеций и будет искомым интегралом.
Площадь трапеции определяется просто: полусумма оснований, умноженная на высоту. Основания в нашем случае - это табличные измеренные значения мощности дозы за 2 последовательных промежутка времени, а высота - это разница времени между двумя измерениями.Как вычислить определённый интеграл в Excel

В нашем примере измерения мощности дозы радиации даётся в мкЗв/час. Переведём это в мкЗв/мин, т.к. данные даются с периодичностью 1 раз в минуту. Это нужно для согласования единиц измерения. Мы не можем брать интеграл по времени, измеряемому в минутах, от величины, измеряемой в часах.
Для перевода просто разделим мощность дозы в мкЗв/час построчно на 60. Добавим ещё один столбец в нашу таблицу. На иллюстрации в столбце "D" в строке 2 вписываем "=С2/60". А потом с помощью маркера заполнения (тянем мышью чёрный прямоугольник в правом нижнем углу ячейки) распространяем эту формулу на все остальные ячейки в столбце "D".Как вычислить определённый интеграл в Excel

Теперь нужно найти площади трапеций за каждый промежуток времени. В столбце "E" будем вычислять по приведённой выше формуле площади трапеций.
Полусумма оснований - это половина суммы двух последовательных мощностей дозы из столбца "D". Так как данные идут с периодом 1 раз в минуту, а мы берём интеграл по времени, выраженному в минутах, то высота каждой трапеции будет равна единице (разница времени между каждыми двумя последовательными измерениями, например, 17ч31м - 17ч30м = 0ч1м).
Получаем формулу в ячейке "E3": "=1/2*(D2+D3)*1". Понятно, что "*1" можно не писать, я сделал это просто для полноты картины. Рисунок поясняет всё более наглядно.
Аналогично, с помощью маркера заполнения, распространяем формулу на весь столбец. Теперь в каждой ячейке столбца "Е" посчитана накопленная доза за 1 минуту полёта.Как вычислить определённый интеграл в Excel

Осталось найти сумму вычисленных площадей трапеций. Можно в ячейке "F2" написать формулу "=СУММ(E:E)", это и будет искомым интегралом - сумма всех значений в столбце "E".
Можно сделать немного сложнее, чтобы определить накопленную дозу в разные моменты полёта. Для этого в ячейке "F4" впишем формулу: "=СУММ(E$3:E4)" и маркером заполнения распространим на весь столбец "F". Обозначение "E$3" говорит программе Excel, что менять индекс первой ячейки, от которой ведём счёт, не нужно.
Построим график по столбцам "F" и "A", т.е. изменение накопленной дозы радиации во времени. Наглядно видно увеличение интеграла, как и должно быть, и окончательное значение накопленной за двухчасовой полёт дозы радиации равно примерно 4,5 микрозиверт.
Таким образом, мы только что нашли определённый интеграл таблично заданной функции в программе Excel на реальном физическом примере.Как вычислить определённый интеграл в Excel


CompleteRepair.Ru